Forum

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

Erreur 404 sur WordPress

Avez-vous déjà rencontré ce problème ?
Oui et je l'ai résolu0 vote · 0,00%
Oui mais je l'ai pas résolu1 vote · 25,00%
Non3 votes · 75,00%
4 participants
12

Bonjour à tous

Depuis plusieurs jours j'ai un problème avec mon site WordPress. J'utilise la version 5.4. en effet, lorsque j'essaie de modifier un article, je suis redirigé vers une page 404 après avoir cliqué sur sauvegarder. j'ai lue sur un forum qu'il faut changer les permaliens, mais cette solution ne marche pas chez moi. Quelqu'un a-t-il une autre solution ?

Merci d'avance !

Bonjour @donald

Avez-vous modifié manuellement le fichier .HTAcess qui se trouve à la racine de votre projet?

Utilisateur supprimé a réagi à ce message.
Utilisateur supprimé
Citation de Cambio Dev le 8 septembre 2020, 10 h 10 min

Bonjour @donald

Avez-vous modifié manuellement le fichier .HTAcess qui se trouve à la racine de votre projet?

Bonjour,

Merci pour le retour. Non, je n'ai pas modifié ce fichier. Sauf si en modifiant les permaliens depuis mon espace d'administration WordPress ça modifie cela.

Bonjour @Donald,  jai récement rencontré un problème du genre mais sauf que le mien concernait uniquement une seule page. J'ai cru au départ que c'était le problème de permaliens mais même en le changeant le problème persistait. 

Au fait le soucis était causait par un adon de mon editeur de contenus qui me générait cette erreur. Lorsque je l'ai retiré tout a été reglé 

Donc premièrement, teste les autres pages si le même problme y est et reviens moi

Cambio Dev et Utilisateur supprimé ont réagi à ce message.
Cambio DevUtilisateur supprimé
Citation de Hemery le 8 septembre 2020, 11 h 17 min

Bonjour @Donald,  jai récement rencontré un problème du genre mais sauf que le mien concernait uniquement une seule page. J'ai cru au départ que c'était le problème de permaliens mais même en le changeant le problème persistait. 

Au fait le soucis était causait par un adon de mon editeur de contenus qui me générait cette erreur. Lorsque je l'ai retiré tout a été reglé 

Donc premièrement, teste les autres pages si le même problme y est et reviens moi

Merci @hemery

En fait j'utilise un plugin LearnPress sur mon site pour vendre des cours en ligne.

C'est lorsque j'essaie de modifier un cours que j'ai cette erreur là. Je suis redirigé vers la page 404

Voici le lien dont j'essaie d'accéder mon_domaine/wp-admin/post.php

Citation de Donald le 8 septembre 2020, 12 h 23 min
Citation de Hemery le 8 septembre 2020, 11 h 17 min

Bonjour @Donald,  jai récement rencontré un problème du genre mais sauf que le mien concernait uniquement une seule page. J'ai cru au départ que c'était le problème de permaliens mais même en le changeant le problème persistait. 

Au fait le soucis était causait par un adon de mon editeur de contenus qui me générait cette erreur. Lorsque je l'ai retiré tout a été reglé 

Donc premièrement, teste les autres pages si le même problme y est et reviens moi

Merci @hemery

En fait j'utilise un plugin LearnPress sur mon site pour vendre des cours en ligne.

C'est lorsque j'essaie de modifier un cours que j'ai cette erreur là. Je suis redirigé vers la page 404

Voici le lien dont j'essaie d'accéder mon_domaine/wp-admin/post.php

C'est bizarre, nous utilisons le même plugin sur cette plateforme mais nous n'avons pas ce problème. Essayez voir de regarder s'il est à jour sur votre installation de WordPress

Utilisateur supprimé a réagi à ce message.
Utilisateur supprimé
Citation de Donald le 8 septembre 2020, 8 h 27 min

Bonjour à tous

Depuis plusieurs jours j'ai un problème avec mon site WordPress. J'utilise la version 5.4. en effet, lorsque j'essaie de modifier un article, je suis redirigé vers une page 404 après avoir cliqué sur sauvegarder. j'ai lue sur un forum qu'il faut changer les permaliens, mais cette solution ne marche pas chez moi. Quelqu'un a-t-il une autre solution ?

Merci d'avance !

Bonjour,

Perso je ne suis pas développeur WordPress, mais une bonne pratique en trouble shooting sera de:

  • Revenir à la dernière version la plus stable (sans aucune erreur)
  • Rajouter les modules un par un (tester entièrement l'application à chaque ajout)
  • Détecter le module qui créer le bug et vérifier ses dépendance et se conflits avec d'autres dépendances dans la doc

A noter que tu peux utiliser le même module qu'une autre personne mais avoir un résultat différent faute de l’environnent ????

Fais se refactoring si tu ne l'a as encore fais, reviens nous avec plus de précisions et la solution va couler d'elle même ????

J'espère avoir été d'une aide utile ????

Jonathan et Utilisateur supprimé ont réagi à ce message.
JonathanUtilisateur supprimé

Bonjour @Donald  je fais pas dans wordpress mais je crois que aller pas à pas depuis la dernière version du code qui fonction et faire l'intégration des modules avec test montrera le souci.
Bonne chance.! Fais nous savoir ici quand tu as la solution

Avant toutes choses il faut bien comprendre qu'il est absolument nécessaire de placer des redirections si la structure des permaliens a changées.  Les liens présents sur des sites tiers qui pointent vers vos articles ne fonctionneront plus après un changement de structure des permaliens. Par conséquent, un visiteur qui accède à une ancienne URL arrivera sur une erreur 404.

Utilisateur supprimé a réagi à ce message.
Utilisateur supprimé
Citation de Abelito le 9 septembre 2020, 16 h 47 min

Avant toutes choses il faut bien comprendre qu'il est absolument nécessaire de placer des redirections si la structure des permaliens a changées.  Les liens présents sur des sites tiers qui pointent vers vos articles ne fonctionneront plus après un changement de structure des permaliens. Par conséquent, un visiteur qui accède à une ancienne URL arrivera sur une erreur 404.

Wow, merci bien @abelito 

C'est très important ce que tu dis. J'en tiendrais compte.

Sauf que là c'est moi même qui reçoit la 404 après modification d'un post

12